PhoneGap中文网

 找回密码
 立即注册

QQ登录

只需一步,快速开始

查看: 1331|回复: 0

bower安装使用入门教程

[复制链接]

485

主题

2012

帖子

6534

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
6534
发表于 2015-10-17 12:26:35 | 显示全部楼层 |阅读模式
bower简介:

一个新的web项目开始,我们总是很自然地去下载需要用到的js类库文件,比如jQuery,去官网下载名为jquery-1.10.2.min.js文件,放到我们的项目里。当项目又需要bootstrap的时候,我们会重复刚才的工作,去bootstrap官网下载对应的类库。如果bootstrap所依赖的jQuery并不是1.10.2,而是2.0.3时,我们会再重新下载一个对应版本的jQuery替换原来的。

包管理是个复杂的问题,我们要知道谁依赖谁,还要明确哪个版本依赖哪个版本。这些对于开发人员来说,负担过重了。bower作为一个js依赖管理的工具,提供一种理想包管理方式,借助了npm的一些思想,为我们提供一个舒服的开发环境。


bower安装:

前期准备

1.需要安装nodejs
2.需要安装git


安装

1.首先你得有node,这里就不多做介绍了

另外,对于windows用户,还需要装msysgit,如下图。注意图二中的那个选项

1.png


1_2.png





2.全局安装bower 通过npm install -g bower

2.png



3.安装成功以后试着在项目文件夹下,下载jquery 和 underscore

bower install jquery underscore

3.png



4.
然后就可以看到项目文件夹下多了一个app文件,里面有bower_components,再就去就是两个插件了包了


4.png













it营
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

关闭

站长推荐上一条 /1 下一条

Archiver|手机版|小黑屋|PhoneGap中文网 ( 京ICP备13027796号-1

GMT+8, 2018-1-20 22:48 , Processed in 0.240553 second(s), 35 queries .

Powered by Discuz! X3.2

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表